installation failure

Having trouble installing Void? Here's the place to come for help.
Post Reply
at-riaze
Posts: 9
https://dekodeco.com.pl/producent-mebli-na-wymiar-w-warszawie-nowoczesne-kuchnie/
Joined: Wed Apr 10, 2024 10:42 am

installation failure

Post by at-riaze »

Hello everyone,

I just created a Void Linux bootable key, and started the installation.
Once the live image has been booted, I cannot log in as root, since everything disappears and I have a black screen.
Here is my configuration.

Processeurs: 20 et 12e Génération Intel CoreTM i7-12700K
Mémoire: 31.1 Gio de la RAM
Processeur graphique: rtx 4060
Fabricant : Gigabyte Technology Co., Ltd.
Nom du produit: B660 GAMING X DDR4

thank you all
User avatar
colin
Posts: 72
Joined: Sun Jan 21, 2024 4:05 am
Location: Germany

Re: installation failure

Post by colin »

hello @at-riaze et bienvenue sur le forum

you did download and verify the iso from the void-site ? https://voidlinux.org/download/

now in the live-system you open the terminal and may type

Code: Select all

sudo su 
or

Code: Select all

su
with password voidlinux

just tried the newest iso (20240314) and there were no issues.....
at-riaze
Posts: 9
Joined: Wed Apr 10, 2024 10:42 am

Re: installation failure

Post by at-riaze »

oid-live-x86_64-20240314-xfce.iso: Réussi

no possibility of having tty or other
pid1
Site Admin
Posts: 81
Joined: Sun Nov 21, 2021 2:50 am
Location: USA

Re: installation failure

Post by pid1 »

Hi,

I you can get to a tty by pressing CTRL + ALT + F1 (or F2, or F3, etc.). Get back to the GUI with F7 (or F8 depending on configuration/wayland/logged in).

Did you set a root password at installation?

Did you create a non-root user during installation?

If you have a non-root user created, login as that user. If you do not have a non-root user, the window manager may be preventing a root login for security. Again, see the above steps to get to a terminal, login as root, and create a non-root user:

Code: Select all

# useradd -m -G users,wheel newusername
# passwd newusername
Linux/BSD since 2001. Void Linux+KDE/Plasma since 2015. Windows? Not even in a virtual machine :D
at-riaze
Posts: 9
Joined: Wed Apr 10, 2024 10:42 am

Re: installation failure

Post by at-riaze »

I think we don't understand each other. when I boot from the usb key, everything is fine until login. 2 seconds then it disappears, I cannot indicate "root" and "void linux" to start the installation.
So no TTY or graphics
User avatar
colin
Posts: 72
Joined: Sun Jan 21, 2024 4:05 am
Location: Germany

Re: installation failure

Post by colin »

maybe there is something wrong with the usb-stick or the iso
I'd suggest to recreate the stick and/or use another one
at-riaze
Posts: 9
Joined: Wed Apr 10, 2024 10:42 am

Re: installation failure

Post by at-riaze »

I just made a boot key and tested it, no problem.

Code: Select all

[francois@fp iso]$ sha256sum -c --ignore-missing sha256sum.txt
void-live-x86_64-20240314-xfce.iso: Réussi
Unfortunately I still get the same result. You will find the steps in photos, it will be simpler, because my English is with the Google translation...
[url][<a href="https://www.casimages.com/i/24041102142826692718386614.jpg.html" title="Mon image">Lien vers mon image</a>/url]
[url]<a href="https://www.casimages.com/i/24041102142926692718386615.jpg.html" title="Mon image">Lien vers mon image</a>[/url]
[url]<a href="https://www.casimages.com/i/24041102143026692718386616.jpg.html" title="Mon image">Lien vers mon image</a>[/url]
[url]<a href="https://www.casimages.com/i/24041102143026692718386617.jpg.html" title="Mon image">Lien vers mon image</a>[/url]
User avatar
colin
Posts: 72
Joined: Sun Jan 21, 2024 4:05 am
Location: Germany

Re: installation failure

Post by colin »

tes photos ne sont pas disponibles
on doit l'envoyer en pièce jointe - voir en bas à gauche de la page -- (ADD FILES)
User avatar
colin
Posts: 72
Joined: Sun Jan 21, 2024 4:05 am
Location: Germany

Re: installation failure

Post by colin »

pid1 wrote: Wed Apr 10, 2024 9:24 pm Hi,

Did you set a root password at installation?

Did you create a non-root user during installation ?
think, he was not able to install, because there is no success for becoming root, so that the command

Code: Select all

sudo void-installer
will be possible to do
at-riaze
Posts: 9
Joined: Wed Apr 10, 2024 10:42 am

Re: installation failure

Post by at-riaze »

2r.JPG
1r.JPG
3r.JPG
Last edited by at-riaze on Thu Apr 11, 2024 10:39 am, edited 2 times in total.
at-riaze
Posts: 9
Joined: Wed Apr 10, 2024 10:42 am

Re: installation failure

Post by at-riaze »

4r.JPG
Last edited by at-riaze on Thu Apr 11, 2024 10:54 am, edited 2 times in total.
pid1
Site Admin
Posts: 81
Joined: Sun Nov 21, 2021 2:50 am
Location: USA

Re: installation failure

Post by pid1 »

Okay I understand now what you are experiencing.

I've had this issue in the past on some hardware. I don't remember exactly what I did to fix it, but for starters it is wise use a text mode in the console and avoid a frame buffer.

Edit the grub default kernel option by changing the "linux" line to include the word "text" after the other options. For example:
linux /boot/vmlinuz-6.6.21 quiet splash text
Linux/BSD since 2001. Void Linux+KDE/Plasma since 2015. Windows? Not even in a virtual machine :D
at-riaze
Posts: 9
Joined: Wed Apr 10, 2024 10:42 am

Re: installation failure

Post by at-riaze »

Following your information, I entered "GNU GRUB". After several modifications of the Linux line
without any results, we fall back on the screen of the last photo.
Edit line :
linux/boot/vmlinuz-6.6.21 quiet splash text "boot not found error"
linux/boot/vmlinuz 6.6.21 quiet splash text "black screen"
linux/boot/vmlinuz quiet splash text "black screen"
linux/boot/vmlinuz splash text "black screen"
linux/boot/vmlinuz text "black screen"


thank you again for your help, because in VM Void works really well
User avatar
colin
Posts: 72
Joined: Sun Jan 21, 2024 4:05 am
Location: Germany

Re: installation failure

Post by colin »

this looks good to me :D

normally the machine switches to GUI by itself in continuing your last picture (page 1)
pid1
Site Admin
Posts: 81
Joined: Sun Nov 21, 2021 2:50 am
Location: USA

Re: installation failure

Post by pid1 »

Try also removing the "quiet" and "splash" command line options.

Try also the above with a VGA mode:

Code: Select all

vga=791
Source: Linux VGA Modes

Last resort, use a Void image that does not have a GUI installed so you will be left with a tty console login and no further GUI trying to start.
Linux/BSD since 2001. Void Linux+KDE/Plasma since 2015. Windows? Not even in a virtual machine :D
at-riaze
Posts: 9
Joined: Wed Apr 10, 2024 10:42 am

Re: installation failure

Post by at-riaze »

Small return, only basic iso works, so installation tomorrow normally.
I will need you to install a desktop and especially to manage the graphics card...
For the moment it is too good to stay inside the house, I keep you informed.
pid1
Site Admin
Posts: 81
Joined: Sun Nov 21, 2021 2:50 am
Location: USA

Re: installation failure

Post by pid1 »

What video card is installed? It might be an issue with a driver.
Linux/BSD since 2001. Void Linux+KDE/Plasma since 2015. Windows? Not even in a virtual machine :D
at-riaze
Posts: 9
Joined: Wed Apr 10, 2024 10:42 am

Re: installation failure

Post by at-riaze »

and here is Void installed, some difficulties with the XFCE desktop.
Problem with RTX4060 board but resolved:)

Thanks again for your feedback
User avatar
colin
Posts: 72
Joined: Sun Jan 21, 2024 4:05 am
Location: Germany

Re: installation failure

Post by colin »

félicitations pour votre succès
Post Reply